Before completing your order, please take a moment to review information about potential delivery delays.

Due to closures, travel restrictions, and prioritization of vital services, some parcel deliveries may experience delays. Please check with your carrier of choice to verify your location can receive deliveries. In some instances, some deliveries may no longer be possible.
Read More.

Uploading via FTP does not work!!

Help! Neither my wife or I can log on to the server using a variety of different clients. Tried filezilla and fetch.

We both tried our usernames eg. johnsmithathotmaildotcom and passwords which work fine on the website but can't log on.

We have had nothing but trouble using this service. Sent a help request a few days ago and have heard nothing back.

This was supposed to be for an anniversary present but won't be ready in time now.



  • When I use FTP for upload to Lulu, I enter the same email address (i.e actually used the at symbol and fullstops/periods in the email address rather than substituting words) with which I log into Lulu, not my user name, and I've never had a problem.
  • I have used Lulu for years, never having major issues until this past week....I have tried unsuccessfully for well over a week 24/7 literally, trying to upload several different pdfs via ftp (in case there was an issue  with one, but there is no way there is an issue with 7 different pdf files)..I have sent in an email for help but no repsonse. The files appear to go but when i go to my files they are not there..anyone else having ftp issues?

  • I've taken to using core ftp lite which works for me as I was experiencing probs with filezilla.





  • I am having similar issues here.  I cannot use the website via FireFox to upload anything, not even small files.  I can't use Filezilla anymore, just throws error at me after 20 minutes saying, "too many retries".  I can sometimes upload using the website, if I use Microsoft Exploder, but even that takes forever -- and often doesn't work at all.  What the heck is going on?  We've been using for years now, and this is the first time I've ever had issue.  Also, putting in help tickets lately seems to be worthless.  They are never handled.  I only get help and answers here on the forums...


    thanks much,


  • I am having the same problem - have used a few different ftp clients to no avail... what the heck? It is getting really frustrating!

  • I've always used Filezilla but today I can't seem to talk to their server no matter what I type in.

  • I uploaded a dvd iso file all last night for 13 hours using filezilla.

    It uploaded fine but isn't showing in myfiles.

  • I have the same problem .... nothing works. The server replys:

    Login authentication failed.

    Ni chance to get in. I had to use the wizard to upload my file.

  • I am using Core Lite. It makes the connection just fine. But once it gets to 85% of the upload it shows the file as havung been transferred across to the Lulu site directory and then just "FAILS" - every time - after 3 F'en hours. Report that the Lulu site has terminated the connection.

    Also will only connect at HTTP "connection" setting  and never at FTP.

    What to do?

  • I've uploaded a validated epub file ok with Transmit, but lulu rejected it because of File Permission setting errors. Anyone else had this? All my files are set to read/write
  • Try using Ipswitch as your FTP client. It's a superior product.

    If anyone is stucuk on a deadline email me the file and I'll do it for you.

  • If that doesn't work, then I would recommend using our Support page. There you can find our Live Chat and Email Support options. Our customer service team currently has an 88% satisfaction rate, so you know you're in good hands!

  • everything always crashes, this is getting really annnnnnoying.

    is there any other way without being a boffin, to upload what is needed for lulu seeing as just uploading always freezes, if your servers are old then maybe they need updating... if not anyone know alternative sites that are good, if not lulu please solve the problem

  • After hours uploading using smart ftp got '

    An established connection was aborted by the software in your host machine.

    Loaded 319mb of 512.

    Now cant connect. Try another FTP I supose. Really hacked of after a sleepless night to be further back in project.


    Used to really rate lulu, but its about time they sorted fundamentals or they will lose people to places like blurb Etc.

  • So, it sounds like I shouldn't bother with Lulu for this small catalog that I want to print. 

    I can't find any of the information that I need on the web site.  The downloaded template folder  provides NO real information and has a link to a page that promises to provide info about onepiece covers - that link only takes me to this forum.  To make matters worse, searching with the term "onepiece" shows no responses at all.

    So Lulu is basically a shell company that provides no info and no customer service.  It collects money for allowing people to flounder around, trying to help each other publish their own books by uploading to a site with no technical support or oversight.

    Is this a joke?

  • Hi lfrench,

    I'm sorry to hear that you've had a difficult time navigating the site. We are always happy to provide help and support; we strive to respond to email support cases within 2-4 business days, but we do occasionally experience high volumes of email requests. You can contact us via live chat as well and chat instantly with a support agent via the support page:

    I would recommend modifying your search on the Connect page to "one-piece", which should pull up a list of articles pertaining to formatting your one-piece cover. Here are a few:[]&publishRangeTime=0&attentionState=no_filter&search_type=message

    Hope this helps!

  • I looked a ipswitch, too expensive. I've never figured out how to use FTP, Filezilla even when I had brains. Quickconnect I entered and it found the IP but didn't connect. And everyone is right, lulu is a frustating service especially for the disabled and poor.

  • I downloaded Core Lite but using is another matter. I need instructions please. I tried quick connect w/ lulu, no dice.
  • Remember I'm trying to function despite a brain tumor and I'm a fixed income. I'm really a sick old man, still trying to function in a world gone mad. I don't figure I have much time left. Really trying to do things on a shoestring. I played w/ the Core Lite, but I'm old-fashioned, I like books. Learning by video doesn't work w/ me and I've never used FTP before. So, if somebody will be kind enough to give instructions that I can print that would be grand. I looked at the detailed instructions and the would take a little bit of forever to print out.

  • OK, I printed it out and I still can't connect. Unfortunately, most computer talk has turned into gobbleygook for me even tho I've built 5 websites. Now all I can do is write, these damned machines baffle me now and I'm living in a place that's very uncomfortable and I spend too much time in front of my machine trying to get something done. I can't process info like I used to, but I'm still trying.
  • Like I said I printed out the instruction, played some more but I can't seem to get to work for me (story of my life right now).
  • Trying to get help w/ this all over. One thing I picked is may not be their server name. What, pray tell, might it be?
  • I think I've been black-balled. I try to connect w/ Core using a password and it says "request denied." The Ertian Chronicles is nearing completion and I'd like to use LULU as a publisher but unless I get real help soon it's going to be a failed project representing 4 years of work. Man Frustrated

Sign In or Register to comment.